New Customer Deployments are currently unavailable
Incident Report for USM Anywhere
Resolved
The issue affecting new deployments has been resolved
Posted 20 days ago. Oct 30, 2018 - 12:34 UTC
Investigating
We are currently investigating an issue that is affecting new customer deployments. New deployments are disabled whilst we look into this.
Posted 20 days ago. Oct 30, 2018 - 11:06 UTC
This incident affected: USM Anywhere Service.