Issue with Deployment of New Trials
Incident Report for USM Anywhere
Resolved
The issue has now been resolved
Posted 11 days ago. Nov 08, 2018 - 15:31 UTC
Investigating
We are currently investigating an issue that is preventing new trial deployments. We will update when more information becomes available.
Posted 11 days ago. Nov 08, 2018 - 15:13 UTC
This incident affected: USM Anywhere Service.