Short service interruption in AMER region
Incident Report for USM Anywhere
Resolved
This incident has been resolved.
Posted Feb 17, 2022 - 08:59 UTC
Identified
There will be a short service outage, due to necessary updates, during the current maintenance window
Posted Feb 17, 2022 - 07:35 UTC
This incident affected: USM Anywhere Service.